Abhängigkeit hibiscus.depotviewer - Installationsfehler

Library hibiscus.ly.toolkit 1.0.5 kein Jameica plugin

 
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 6
Dabei seit: 12 / 2018
Betreff:

Abhängigkeit hibiscus.depotviewer - Installationsfehler

 · 
Gepostet: 02.12.2018 - 15:15 Uhr  ·  #1
Hallo zusammen,

beim Versuch hibiscus.depotviewer (0.5.5) zu installieren konnte ich die Abhängigkeiten
1) hibiscus.scripting.selenium (v3.14.0)
2) hibiscus.scripting.chromedriver (v2.42.0)
auflösen.
Installiertes System:
Jameica Version: 2.8.2
Hibiscus Version: 2.8.6

Beim Versuch die Abhängigkeit:
hibiscus.ly.toolkit (v1.0.5) - Libraries von (http://www.open4me.de/hibiscus/)
zu installieren erhalte ich allerdings folgende Fehlermeldung:

Zitat

[02.12.2018 15:09:06] Download von http://www.open4me.de/hibiscus…oolkit.zip
[02.12.2018 15:09:06] Download beendet
[02.12.2018 15:09:06] Kein gültiges Jameica-Plugin


Zuvor wurde noch angezeigt, dass die erwähnten plugins nicht signiert seien - ich hoffe das ist kein Problem.
Mich wundert auch, dass hier nicht mit SSL gearbeitet wird...
Ich habe über "Repositories bearbeiten" einmal open4me.de mit https hinzugefügt, aber keine Änderung beobachtet - exakt gleiche Fehlermeldung.

Habe ich irgendwo etwas übersehen oder ist der Fehler bekannt?
An anderen Stellen (relativ aktuell 2018) habe ich gesehen, dass Menschen den depotviewer offenbar problemlos installieren konnten.

Beste Grüße
Arma
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 6461
Dabei seit: 03 / 2005
Betreff:

Re: Abhängigkeit hibiscus.depotviewer - Installationsfehler

 · 
Gepostet: 03.12.2018 - 10:32 Uhr  ·  #2
Zitat geschrieben von arma7

Beim Versuch die Abhängigkeit:
hibiscus.ly.toolkit (v1.0.5) - Libraries von (http://www.open4me.de/hibiscus/)
zu installieren erhalte ich allerdings folgende Fehlermeldung:

Zitat

[02.12.2018 15:09:06] Download von http://www.open4me.de/hibiscus…oolkit.zip
[02.12.2018 15:09:06] Download beendet
[02.12.2018 15:09:06] Kein gültiges Jameica-Plugin



Den Fehler kann ich nicht reproduzieren. Habe es gerade mal getestet:

1) Die beiden Repositories https://scripting-updates.derrichter.de/ und https://www.open4me.de/hibiscus/ hinzugefuegt
2) Plugin "hibiscus.ly.toolkit" zur Installation ausgewaehlt
3) Die noetigen Abhaengigkeiten werden automatisch mit installiert.
4) Kein Fehler nach dem naechsten Start.

Zitat geschrieben von arma7

Zuvor wurde noch angezeigt, dass die erwähnten plugins nicht signiert seien - ich hoffe das ist kein Problem.


Nicht jeder Autor signiert seine Plugins. Die automatisch erstellten Nightly-Builds von Hibiscus z.Bsp. sind auch nicht signiert.

Zitat geschrieben von arma7

Mich wundert auch, dass hier nicht mit SSL gearbeitet wird...


Das Repository von Sven (open4me.de) ist in Jameica seit April 2017 per Default bei Neuinstallationen als HTTPS hinterlegt. Ich nehme an, deine Jameica-Installation ist aelter und daher stand die URL dort noch als HTTP drin.

Zitat geschrieben von arma7

Habe ich irgendwo etwas übersehen oder ist der Fehler bekannt?
An anderen Stellen (relativ aktuell 2018) habe ich gesehen, dass Menschen den depotviewer offenbar problemlos installieren konnten.


Ich konnte den Fehler jetzt wie gesagt auch nicht reproduzieren. Schau doch mal in die jameica.log - vielleicht findet sich dort ja noch etwas.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 6
Dabei seit: 12 / 2018
Betreff:

Re: Abhängigkeit hibiscus.depotviewer - Installationsfehler

 · 
Gepostet: 03.12.2018 - 10:59 Uhr  ·  #3
Danke für deine schnelle Antwort - schade, aber auch gut, dass es nichts generelles ist. :)

Ich habe über "Repositories bearbeiten" jetzt die alten (ohne SSL) rausgenommen und die gleichen URLs mit https wieder eingefügt.

Nach einem Neustart von Jameica bin ich zunächst auf Einstellungen>Plugins>Updates gegangen und habe eine neue "Frage / Fehlermeldung" bekommen, die ich zuvor nicht hatte - wohl ausgelöst durch die Änderung des Repos mit https?
Zitat

Der Hostname "scripting-updates.derrichter.de" stimmt mit keinem der Server-Zertifikate überein (*.kontent.com,COMODO RSA Organization Validation Secure Server CA,COMODO RSA Certification Authority). Wollen Sie den Vorgang dennoch fortsetzen?

Einen Tippfehler kann ich leider nicht erkennen. - Wo kann/muss ich jetzt noch was bzgl. der Zertifikate aktualisieren?

Danke für den Hinweis auf das Logfile, offensichtlich habe ich ein Fehler mit dem zipfile.
Etwas sonderbar finde ich, dass hier:
http://www.open4me.de/hibiscus…oolkit.zip
(ohne ssl heruntergeladen werden soll, obwohl das Repository einen Neustart zuvor ausgetauscht wurde. - Kann es sein, dass es über http gar nicht mehr zu laden geht? Oder bin ich da auf dem falschen Dampfer und der Fehler liegt ganz woanders?)
Hier der Ausschnitt aus dem jameica.log:

Code

[Mon Dec 03 10:38:05 CET 2018][INFO][main][de.willuhn.jameica.update.Repository.<init>] open repository https://scripting-updates.derrichter.de/
[Mon Dec 03 10:38:05 CET 2018][INFO][main][de.willuhn.jameica.transport.HttpTransport.get] downloading https://scripting-updates.derrichter.de/repository.xml
[Mon Dec 03 10:38:54 CET 2018][WARN][main][de.willuhn.jameica.update.PluginGroup.initCertificate] no certificate given
[Mon Dec 03 10:38:54 CET 2018][INFO][main][de.willuhn.jameica.transport.HttpTransport.get] downloading http://scripting-updates.derrichter.de/updates/htmlunit/plugin.xml
[Mon Dec 03 10:38:55 CET 2018][INFO][main][de.willuhn.jameica.transport.HttpTransport.get] downloading http://scripting-updates.derrichter.de/updates/pdfbox/plugin.xml
[Mon Dec 03 10:38:55 CET 2018][INFO][main][de.willuhn.jameica.transport.HttpTransport.get] downloading http://scripting-updates.derrichter.de/updates/selenium/plugin.xml
[Mon Dec 03 10:38:55 CET 2018][INFO][main][de.willuhn.jameica.transport.HttpTransport.get] downloading http://scripting-updates.derrichter.de/updates/chromedriver/plugin.xml
[Mon Dec 03 10:38:55 CET 2018][INFO][main][de.willuhn.jameica.transport.HttpTransport.get] downloading http://scripting-updates.derrichter.de/updates/phantomjsdriver/plugin.xml
[Mon Dec 03 10:38:55 CET 2018][WARN][main][de.willuhn.jameica.update.PluginGroup.initCertificate] no certificate given
[Mon Dec 03 10:38:55 CET 2018][INFO][main][de.willuhn.jameica.transport.HttpTransport.get] downloading http://scripting-updates.derrichter.de/updates/finance.websync/plugin.xml
[Mon Dec 03 10:38:55 CET 2018][INFO][main][de.willuhn.jameica.transport.HttpTransport.get] downloading http://scripting-updates.derrichter.de/updates/hibiscus.mashup/plugin.xml
[Mon Dec 03 10:38:55 CET 2018][WARN][main][de.willuhn.jameica.update.PluginGroup.initCertificate] no certificate given
[Mon Dec 03 10:38:55 CET 2018][INFO][main][de.willuhn.jameica.transport.HttpTransport.get] downloading http://hibiscus.strunk.eu/lbbcreditcard/plugin.xml
[Mon Dec 03 10:39:00 CET 2018][INFO][main][de.willuhn.jameica.services.RepositoryService.downloadMulti] checking if plugin hibiscus.ly.toolkit is signed
[Mon Dec 03 10:39:00 CET 2018][INFO][main][de.willuhn.jameica.services.RepositoryService.downloadMulti] checking if plugin hibiscus.depotviewer is signed
[Mon Dec 03 10:39:03 CET 2018][INFO][bg-task:][de.willuhn.jameica.services.RepositoryService$1.run] checking if plugin hibiscus.ly.toolkit is signed
[Mon Dec 03 10:39:03 CET 2018][INFO][bg-task:][de.willuhn.jameica.services.RepositoryService$1.run] creating deploy file C:\Users\arma\.jameica\updates\hibiscus.ly.toolkit.zip
[Mon Dec 03 10:39:03 CET 2018][INFO][bg-task:][de.willuhn.jameica.transport.HttpTransport.get] downloading http://www.open4me.de/hibiscus/hibiscus.ly.toolkit/hibiscus.ly.toolkit.zip
[Mon Dec 03 10:39:03 CET 2018][INFO][bg-task:][de.willuhn.jameica.gui.internal.parts.BackgroundTaskMonitor.check] creating progress monitor for GUI
[Mon Dec 03 10:39:03 CET 2018][INFO][main][de.willuhn.jameica.gui.internal.parts.BackgroundTaskMonitor$2.run] activating progress monitor
[Mon Dec 03 10:39:03 CET 2018][ERROR][bg-task:][de.willuhn.jameica.plugin.ZippedPlugin.<init>] unable to check zip file C:\Users\arma\.jameica\updates\hibiscus.ly.toolkit.zip
java.util.zip.ZipException: zip file is empty
  at java.util.zip.ZipFile.open(Native Method)
  at java.util.zip.ZipFile.<init>(Unknown Source)
  at java.util.zip.ZipFile.<init>(Unknown Source)
  at de.willuhn.jameica.plugin.ZippedPlugin.<init>(ZippedPlugin.java:53)
  at de.willuhn.jameica.services.RepositoryService$1.run(RepositoryService.java:340)
  at de.willuhn.jameica.gui.GUI$7.run(GUI.java:1060)

[Mon Dec 03 10:39:03 CET 2018][INFO][bg-task:][de.willuhn.jameica.services.RepositoryService$1.run] deleting C:\Users\arma\.jameica\updates\hibiscus.ly.toolkit.zip
[Mon Dec 03 10:39:33 CET 2018][INFO][main][de.willuhn.jameica.gui.internal.parts.BackgroundTaskMonitor$1$1.run] auto closing monitor snapin
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 6461
Dabei seit: 03 / 2005
Betreff:

Re: Abhängigkeit hibiscus.depotviewer - Installationsfehler

 · 
Gepostet: 03.12.2018 - 11:23 Uhr  ·  #4
Zitat geschrieben von arma7

Nach einem Neustart von Jameica bin ich zunächst auf Einstellungen>Plugins>Updates gegangen und habe eine neue "Frage / Fehlermeldung" bekommen, die ich zuvor nicht hatte - wohl ausgelöst durch die Änderung des Repos mit https?
Zitat

Der Hostname "scripting-updates.derrichter.de" stimmt mit keinem der Server-Zertifikate überein (*.kontent.com,COMODO RSA Organization Validation Secure Server CA,COMODO RSA Certification Authority). Wollen Sie den Vorgang dennoch fortsetzen?

Einen Tippfehler kann ich leider nicht erkennen. - Wo kann/muss ich jetzt noch was bzgl. der Zertifikate aktualisieren?


Da stimmt bei dir auf dem Rechner irgendwas nicht. Wenn ich https://scripting-updates.derrichter.de im Browser eingebe und mit dort die Zertifikatsdetails anschaue, dann ist der Hostname, auf den das Zertifikat ausgestellt ist, korrekt. Von "kontent.com" steht da nichts. Hier muesstest du dich eventuell mal an Sebastian wenden. Er betreibt ja dieses Repository.

Aber wie gesagt: Bei mir hat dieses Repository ein gueltiges Zertifikat von Let's Encrypt. Vielleicht hast du da ja noch eine weitere Repository-URL drin stehen.

Zitat geschrieben von arma7

Etwas sonderbar finde ich, dass hier:
http://www.open4me.de/hibiscus…oolkit.zip
(ohne ssl heruntergeladen werden soll, obwohl das Repository einen Neustart zuvor ausgetauscht wurde. - Kann es sein, dass es über http gar nicht mehr zu laden geht? Oder bin ich da auf dem falschen Dampfer und der Fehler liegt ganz woanders?)


Die Tatsache, dass das Repository selbst per HTTPS eingerichtet ist, heisst leider noch nicht, dass die eigentlichen Downloads dann auch per HTTPS kommen. Hier kommt es darauf an, wie die Downloads im Repository verlinkt sind. Das Repository-XML selbst (http://www.open4me.de/hibiscus/repository.xml) enthaelt:

Code

<plugin url="https://www.open4me.de/hibiscus/hibiscus.ly.toolkit"/>


Bis hier ist noch HTTPS. Die zugehoerige Plugin-Datei unter "https://www.open4me.de/hibiscus/hibiscus.ly.toolkit/plugin.xml" enthaelt als Download-Link jedoch:

Code

<url>http://www.open4me.de/hibiscus/hibiscus.ly.toolkit/hibiscus.ly.toolkit.zip</url>


Das muesste Sven, der Autor des Plugins, mal noch auf HTTPS umstellen.

Zitat geschrieben von arma7

Hier der Ausschnitt aus dem jameica.log:

Code

[de.willuhn.jameica.transport.HttpTransport.get] downloading http://www.open4me.de/hibiscus/hibiscus.ly.toolkit/hibiscus.ly.toolkit.zip
[Mon Dec 03 10:39:03 CET 2018][INFO][bg-task:][de.willuhn.jameica.gui.internal.parts.BackgroundTaskMonitor.check] creating progress monitor for GUI
[Mon Dec 03 10:39:03 CET 2018][INFO][main][de.willuhn.jameica.gui.internal.parts.BackgroundTaskMonitor$2.run] activating progress monitor
[Mon Dec 03 10:39:03 CET 2018][ERROR][bg-task:][de.willuhn.jameica.plugin.ZippedPlugin.<init>] unable to check zip file C:\Users\arma\.jameica\updates\hibiscus.ly.toolkit.zip
java.util.zip.ZipException: zip file is empty
  at java.util.zip.ZipFile.open(Native Method)



Kann ich nicht reproduzieren. Wenn ich die Datei runterlade, ist sie nicht leer sondern enthaelt ein gueltiges Plugin. Irgendwas stimmt da auf deinem Rechner nicht.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 6
Dabei seit: 12 / 2018
Betreff:

Re: Abhängigkeit hibiscus.depotviewer - Installationsfehler

 · 
Gepostet: 03.12.2018 - 15:25 Uhr  ·  #5
Zitat

Da stimmt bei dir auf dem Rechner irgendwas nicht. Wenn ich https://scripting-updates.derrichter.de im Browser eingebe und mit dort die Zertifikatsdetails anschaue, dann ist der Hostname, auf den das Zertifikat ausgestellt ist, korrekt. Von "kontent.com" steht da nichts. Hier muesstest du dich eventuell mal an Sebastian wenden. Er betreibt ja dieses Repository.

Aber wie gesagt: Bei mir hat dieses Repository ein gueltiges Zertifikat von Let's Encrypt. Vielleicht hast du da ja noch eine weitere Repository-URL drin stehen.

Unter "Plugin-Repositories" stehen bei mir nur folgende
URL
https://www.willuhn.de/products/jameica/updates
https://www.willuhn.de/products/jameica/updates/extensions
https://www.open4me.de/hibiscus/
https://scripting-updates.derrichter.de/

keine weiteren. - Von kontent.com weiß ich ehrlich gesagt auch nichts und der Hinweis kam beim Abrufen von Updates für jameica bisher auch nie. Deswegen habe ich auf jameica/hibiscus getippt.

Ich habe jetzt das Zertifikat von https://scripting-updates.derrichter.de/ über den Browser gespeichert und bei jameica manuell hinzugefügt, jetzt wird es in der Liste der installierten SSL-Zertifikate aufgeführt, daher gehe ich mal davon aus, dass dieses Vorgehen funktioniert hat - oder wie würde ich regulär ein Zertifikat von einem der Repos hinzufügen?

Die 'Fehlermeldung' bleibt bei "Updates suchen" allerdings die gleiche und sie ist neu, seit ich das Repository manuell auf SSL umgestellt habe. (s.o.)
Wenn du das für nicht weiter relevant hältst, dann würde ich das jetzt ignorieren.
Ich könnte es auch weiterverfolgen, um bei der Ursachenforschung zu unterstützen. Aber da ich auf Anhieb nicht wüsste wie, bräuchte ich dann noch ein paar hilfreiche Hinweise, was ich testen/nachforschen soll.

Zitat

Code

<plugin url="https://www.open4me.de/hibiscus/hibiscus.ly.toolkit"/>


Bis hier ist noch HTTPS. Die zugehoerige Plugin-Datei unter "https://www.open4me.de/hibiscus/hibiscus.ly.toolkit/plugin.xml" enthaelt als Download-Link jedoch:

Code

<url>http://www.open4me.de/hibiscus/hibiscus.ly.toolkit/hibiscus.ly.toolkit.zip</url>


Das muesste Sven, der Autor des Plugins, mal noch auf HTTPS umstellen.

Wie erfährt Sven davon? - Danke, dann wird das jetzt sicherlich fix gefixt :)

Zitat

Zitat geschrieben von arma7

Hier der Ausschnitt aus dem jameica.log:

Code

[de.willuhn.jameica.transport.HttpTransport.get] downloading http://www.open4me.de/hibiscus/hibiscus.ly.toolkit/hibiscus.ly.toolkit.zip
[Mon Dec 03 10:39:03 CET 2018][INFO][bg-task:][de.willuhn.jameica.gui.internal.parts.BackgroundTaskMonitor.check] creating progress monitor for GUI
[Mon Dec 03 10:39:03 CET 2018][INFO][main][de.willuhn.jameica.gui.internal.parts.BackgroundTaskMonitor$2.run] activating progress monitor
[Mon Dec 03 10:39:03 CET 2018][ERROR][bg-task:][de.willuhn.jameica.plugin.ZippedPlugin.<init>] unable to check zip file C:\Users\arma\.jameica\updates\hibiscus.ly.toolkit.zip
java.util.zip.ZipException: zip file is empty
  at java.util.zip.ZipFile.open(Native Method)



Kann ich nicht reproduzieren. Wenn ich die Datei runterlade, ist sie nicht leer sondern enthaelt ein gueltiges Plugin. Irgendwas stimmt da auf deinem Rechner nicht.

Ich glaube ehrlich gesagt nicht, dass es etwas mit meinem Rechner zu tun hat, leider.

Ich habe beide plugins (toolkit und depotviewer) jetzt als zip-file manuell heruntergeladen und beide über die Installation als lokale Plugins hinzugefügt. Mit Neustart - ohne Probleme akzeptiert. Auch gleich eingerichtet und es synchronisiert den Bestand ohne Probleme.

Damit kann ich auch gut leben :D - und es dabei bewenden lassen. Es bleibt aber bei dem Hinweis, dass die Installations-/Updateroutine in diesem Fall (zumindest bei mir) nicht reibungslos funktioniert hat.
Ich kann dem gerne weiter nachgehen, bräuchte dafür aber deine/eure Hilfe bzw. Anweisungen.

An der Stelle: Meinen gaaanz großen Dank für deine schnelle Hilfe und Antworten und für die Pflege/Entwicklung der hibiscus-Software!! :fgrin: :-)


Um noch etwas einzugrenzen, wo der/die Fehler womöglich liegen:
Ich habe das Plugin hibiscus.duplikate von Sven installiert. Diesmal nicht manuell sondern ganz normal wie vorher über
Einstellungen>Plugins>Verfügbare Plugins>> Installieren...

Das hat völlig problemlos funktioniert.
Logfile hier:
Code

[Mon Dec 03 15:06:41 CET 2018][INFO][bg-task:][de.willuhn.jameica.update.Repository$1.run] checking if plugin hibiscus.duplikate is signed
[Mon Dec 03 15:06:41 CET 2018][INFO][bg-task:][de.willuhn.jameica.transport.HttpTransport.get] downloading https://www.open4me.de/hibiscus/hibiscus.duplikate/hibiscus.duplikate.zip.sha1
[Mon Dec 03 15:06:42 CET 2018][INFO][bg-task:][de.willuhn.jameica.update.Repository$1.run] created signature file C:\Users\arma\.jameica\updates\hibiscus.duplikate.zip.sha1
[Mon Dec 03 15:06:42 CET 2018][INFO][bg-task:][de.willuhn.jameica.update.Repository$1.run] creating deploy file C:\Users\arma\.jameica\updates\hibiscus.duplikate.zip
[Mon Dec 03 15:06:42 CET 2018][INFO][bg-task:][de.willuhn.jameica.transport.HttpTransport.get] downloading https://www.open4me.de/hibiscus/hibiscus.duplikate/hibiscus.duplikate.zip
[Mon Dec 03 15:06:42 CET 2018][INFO][bg-task:][de.willuhn.jameica.gui.internal.parts.BackgroundTaskMonitor.check] creating progress monitor for GUI
[Mon Dec 03 15:06:42 CET 2018][INFO][main][de.willuhn.jameica.gui.internal.parts.BackgroundTaskMonitor$2.run] activating progress monitor
[Mon Dec 03 15:06:42 CET 2018][INFO][bg-task:][de.willuhn.jameica.services.RepositoryService.checkSignature] checking signature C:\Users\arma\.jameica\updates\hibiscus.duplikate.zip.sha1 of file C:\Users\arma\.jameica\updates\hibiscus.duplikate.zip
[Mon Dec 03 15:06:42 CET 2018][INFO][bg-task:][de.willuhn.jameica.services.RepositoryService.checkSignature] signature of plugin hibiscus.duplikate OK
[Mon Dec 03 15:06:42 CET 2018][INFO][bg-task:][de.willuhn.jameica.security.JameicaSecurityManager.doPrivileged] [privcount: 0] starting privileged action: writable check for C:\Users\arma\Portables\jameica-win64\jameica\plugins
[Mon Dec 03 15:06:42 CET 2018][INFO][bg-task:][de.willuhn.jameica.security.JameicaSecurityManager.doPrivileged] [privcount: 0] finished privileged action: writable check for C:\Users\arma\Portables\jameica-win64\jameica\plugins
[Mon Dec 03 15:06:42 CET 2018][INFO][main][de.willuhn.jameica.security.JameicaSecurityManager.doPrivileged] [privcount: 0] starting privileged action: writable check for C:\Users\arma\Portables\jameica-win64\jameica\plugins
[Mon Dec 03 15:06:42 CET 2018][INFO][main][de.willuhn.jameica.security.JameicaSecurityManager.doPrivileged] [privcount: 0] finished privileged action: writable check for C:\Users\arma\Portables\jameica-win64\jameica\plugins
[Mon Dec 03 15:06:46 CET 2018][INFO][bg-task:][de.willuhn.jameica.services.DeployService.deploy] extracting C:\Users\arma\.jameica\updates\hibiscus.duplikate.zip to C:\Users\arma\.jameica\plugins\hibiscus.duplikate
[Mon Dec 03 15:06:46 CET 2018][INFO][bg-task:][de.willuhn.io.ZipExtractor.extract] extracting zip file C:\Users\arma\.jameica\updates\hibiscus.duplikate.zip to C:\Users\arma\.jameica\plugins
[Mon Dec 03 15:06:46 CET 2018][INFO][bg-task:][de.willuhn.io.ZipExtractor.extract] hibiscus.duplikate/
[Mon Dec 03 15:06:46 CET 2018][INFO][bg-task:][de.willuhn.io.ZipExtractor.extract] hibiscus.duplikate/hibiscus.duplikate.jar
[Mon Dec 03 15:06:46 CET 2018][INFO][bg-task:][de.willuhn.io.ZipExtractor.extract] hibiscus.duplikate/plugin.xml
[Mon Dec 03 15:06:46 CET 2018][INFO][bg-task:][de.willuhn.jameica.services.DeployService.deploy] plugin successfully deployed
[Mon Dec 03 15:06:46 CET 2018][INFO][bg-task:][de.willuhn.jameica.plugin.Manifest.<init>] hibiscus.duplikate 1.0.2
[Mon Dec 03 15:06:46 CET 2018][INFO][bg-task:][de.willuhn.jameica.plugin.Manifest.<init>]   Directory  : C:\Users\arma\.jameica\plugins\hibiscus.duplikate
[Mon Dec 03 15:06:46 CET 2018][INFO][bg-task:][de.willuhn.jameica.plugin.Manifest.<init>]   Buildnumber: 37
[Mon Dec 03 15:06:46 CET 2018][INFO][bg-task:][de.willuhn.jameica.plugin.Manifest.<init>]   Built-Date : 20160319
[Mon Dec 03 15:06:46 CET 2018][INFO][bg-task:][de.willuhn.jameica.update.Repository$1.run] deleting C:\Users\arma\.jameica\updates\hibiscus.duplikate.zip
[Mon Dec 03 15:06:46 CET 2018][INFO][bg-task:][de.willuhn.jameica.update.Repository$1.run] delete signature C:\Users\arma\.jameica\updates\hibiscus.duplikate.zip.sha1
[Mon Dec 03 15:07:16 CET 2018][INFO][main][de.willuhn.jameica.gui.internal.parts.BackgroundTaskMonitor$1$1.run] auto closing monitor snapin


Außerdem habe ich bei den Repositories nochmal
http://scripting-updates.derrichter.de hinzugefügt
und
https://scripting-updates.derrichter.de deaktiviert.
Die Fehlermeldung beim Suchen nach Updates ist (wie zu erwarten) verschwunden.
Dann habe ich es umgedreht und wieder das Repo mit SSL aktiviert und das ohne SSL deaktiviert.
Nach einem Neustart ist die gleich Frage/Fehlermeldung (s.o.) wieder da.
Also zumindest ist es bei mir in dieser Weise reproduzierbar.
--> Falls ihr das weiterverfolgen wollt: Welches Zertifikat habt ihr wie für die scripting-updates installiert?

Beste Grüße arma
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 6461
Dabei seit: 03 / 2005
Betreff:

Re: Abhängigkeit hibiscus.depotviewer - Installationsfehler

 · 
Gepostet: 03.12.2018 - 15:38 Uhr  ·  #6
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 6
Dabei seit: 12 / 2018
Betreff:

Re: Abhängigkeit hibiscus.depotviewer - Installationsfehler

 · 
Gepostet: 03.12.2018 - 17:46 Uhr  ·  #7
Danke nochmal bis hierhin - das mache ich.
Wenn wir zu Ergebnissen kommen, dann poste ich hier nochmal, damit möglichst Problembeschreibung und ggf. Lösung beeinander sind für weitere auf der Suche nach womöglich ähnlichen Problembeschreibungen.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 106
Dabei seit: 05 / 2014
Betreff:

Re: Abhängigkeit hibiscus.depotviewer - Installationsfehler

 · 
Gepostet: 03.12.2018 - 18:39 Uhr  ·  #8
Das ursprüngliche Problem entsteht, wenn eine http Verbindung auf eine https weitergeleitet wird. Das mag Java nicht. Diesen Problem hat Olaf in Jameica schon korrigiert. Aber diese Korrektur ist (glaube ich) noch nicht in der Release-Version.

In der Zwischenzeit hatte ich einen Workaround installiert, der dies Problem umgehen sollte. Durch eine Änderung funktionierte dieser Workaround aber nicht mehr.

Das Problem sollte seit heute mittag nicht mehr auftreten.


BTW:
Da die Fragen häufiger kommt. Zur Zeit habe ich im Depotviewer keine Lösung, die historische Aktienkurse automatisch abrufen könnte. Im Moment ist nur ein CSV-Import von historischen
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 6
Dabei seit: 12 / 2018
Betreff:

Re: Abhängigkeit hibiscus.depotviewer - Installationsfehler

 · 
Gepostet: 04.12.2018 - 10:21 Uhr  ·  #9
Cool, danke fürs schnelle Kümmern. :)

Ich habe die Schritte jetzt nochmal nachvollzogen.
In den Repos ist https://www.open4me.de/hibiscus/ hinterlegt.
Das zuvor manuell installierte Plugin depotviewer entfernt. (Neustart)
Unter verfügbare Plugins -> Repo open4me/hibiscus ausgewählt, hibiscus.depotviewer installiert
-> lädt jetzt auch wirklich über die https Url herunter. (Neustart)
Funktioniert einwandfrei, hat auch die schon gespeicherten Nutzerdaten gleich wieder übernommen.

NUR nun ist mir ein Punkt aufgefallen, den nicht so schön finde.
Ich hatte im Zuge der o.g. Schritte die installierten SSL-Zertifikate aufgeräumt und die gelöscht, deren Gültigkeit abgelaufen war. (btw - kleiner Punkt für den Bugtracker, die könnten auch automatisch entfernt werden ;) - stört ja aber mWn auch nicht)
--> ein Zertifikat war "komisch" --> bursch.com (Let's Encrypt), da ich keinen Bezug zu jameica/hibiscus erkennen konnte, ebenfalls entfernt. Zumal der Aufruf von bursch.com im Browser zu einer 'Nicht-Seite' führt, die auch keine autom. Weiterleitung auf https hat, also zunächst mal als unsicher vom Browser bezeichnet wird. (https://bursch.com ist erreichbar)

Bei o.g. Neuinstallation des Plugins Depotviewer wurde ich nach Auswahl des open4me.de Repos aufgefordert eben selbiges Zertifikat von bursch.com wieder zu installieren. --> hier besteht offenbar ein Zusammenhang, der sich dem normalen Nutzer nicht erschließt und eher fishy als vertrauensfördernd wirkt ;)
--> vielleicht magst du mal deine Zertifikate aufräumen - bei Gelegenheit... ;)

beste Grüße und nochmal vielen Dank für die super Arbeit, auch hier im Forum
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 6
Dabei seit: 12 / 2018
Betreff:

Re: Abhängigkeit hibiscus.depotviewer - Installationsfehler

 · 
Gepostet: 04.12.2018 - 10:24 Uhr  ·  #10
Zitat geschrieben von little.yoda

BTW:
Da die Fragen häufiger kommt. Zur Zeit habe ich im Depotviewer keine Lösung, die historische Aktienkurse automatisch abrufen könnte. Im Moment ist nur ein CSV-Import von historischen


Das hatte ich schon gelesen, kann man gut finden, wenn man sich vorher was durchliest. :) Alles gut, mir reicht das erstmal, mich nicht jedesmal einloggen zu müssen, nur um zu sehen, ob die Order wirklich ausgeführt wurde oder nicht. Aber es ist doch aktuell die beste Lösung für Depots, die es für jameica/hibiscus gibt! :D
Gewählte Zitate für Mehrfachzitierung:   0