Fehlermeldung bei Auswertungen

 
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 2
Dabei seit: 11 / 2023
Betreff:

Fehlermeldung bei Auswertungen

 · 
Gepostet: 08.11.2023 - 06:06 Uhr  ·  #1
Hallo,
ich bekomme seit ein paar Tagen ein unerwarteter Fehler wenn ich einen der Punkte unter Auswertungen anklicke (Umsätze nach Kategorien, Einnahmen/Ausgaben oder Sparquote).

Im Voraus vielen Dank für die Rückmeldung
Jürgen

Code
*** System-Informationen ***

Jameica: 2.8.0 (build date: 20180522)

Plugins:
  jameica.ca 2.9.0-nightly(build date: 20180621)
  jameica.ical 2.9.0-nightly(build date: 20180703)
  hibiscus 2.10.15(build date: 20231103)
  syntax 2.10.4(build date: 20230206)

os.arch          : amd64
os.name          : Windows 10
os.version       : 10.0

java.version     : 1.8.0_391
java.vendor      : Oracle Corporation
java.runtime.name: Java(TM) SE Runtime Environment
java.vm.name     : Java HotSpot(TM) 64-Bit Server VM

file.encoding    : Cp1252


*** Stacktrace ***

java.lang.UnsupportedClassVersionError: org/eclipse/swtchart/Chart has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
  at java.lang.ClassLoader.defineClass1(Native Method)
  at java.lang.ClassLoader.defineClass(Unknown Source)
  at java.security.SecureClassLoader.defineClass(Unknown Source)
  at java.net.URLClassLoader.defineClass(Unknown Source)
  at java.net.URLClassLoader.access$100(Unknown Source)
  at java.net.URLClassLoader$1.run(Unknown Source)
  at java.net.URLClassLoader$1.run(Unknown Source)
  at java.security.AccessController.doPrivileged(Native Method)
  at java.net.URLClassLoader.findClass(Unknown Source)
  at java.lang.ClassLoader.loadClass(Unknown Source)
  at java.lang.ClassLoader.loadClass(Unknown Source)
  at de.willuhn.jameica.hbci.gui.parts.UmsatzTypVerlauf.paint(UmsatzTypVerlauf.java:146)
  at de.willuhn.jameica.hbci.gui.views.UmsatzTypTree.bind(UmsatzTypTree.java:146)
  at de.willuhn.jameica.gui.GUI$5.run(GUI.java:702)
  at org.eclipse.swt.custom.BusyIndicator.showWhile(Unknown Source)
  at de.willuhn.jameica.gui.GUI$6.run(GUI.java:899)
  at org.eclipse.swt.widgets.Synchronizer.syncExec(Unknown Source)
  at org.eclipse.swt.widgets.Display.syncExec(Unknown Source)
  at de.willuhn.jameica.gui.GUI.startSync(GUI.java:895)
  at de.willuhn.jameica.gui.GUI.startView(GUI.java:593)
  at de.willuhn.jameica.gui.GUI.startView(GUI.java:528)
  at de.willuhn.jameica.hbci.gui.action.UmsatzTypTree.handleAction(UmsatzTypTree.java:28)
  at de.willuhn.jameica.gui.Navigation.start(Navigation.java:371)
  at de.willuhn.jameica.gui.Navigation.access$500(Navigation.java:47)
  at de.willuhn.jameica.gui.Navigation$MyActionListener.handleEvent(Navigation.java:466)
  at org.eclipse.swt.widgets.EventTable.sendEvent(Unknown Source)
  at org.eclipse.swt.widgets.Display.sendEvent(Unknown Source)
  at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
  at org.eclipse.swt.widgets.Display.runDeferredEvents(Unknown Source)
  at org.eclipse.swt.widgets.Display.readAndDispatch(Unknown Source)
  at de.willuhn.jameica.gui.GUI.loop(GUI.java:916)
  at de.willuhn.jameica.gui.GUI.init(GUI.java:327)
  at de.willuhn.jameica.system.Application.init(Application.java:145)
  at de.willuhn.jameica.system.Application.newInstance(Application.java:87)
  at de.willuhn.jameica.Main.main(Main.java:75)
Benutzer
Avatar
Geschlecht:
Beiträge: 6852
Dabei seit: 06 / 2008
Betreff:

Re: Fehlermeldung bei Auswertungen

 · 
Gepostet: 08.11.2023 - 07:15 Uhr  ·  #2
Zitat
(build date: 20180522)
....
Plugins: ...(build date: 20180621)
....(build date: 20180703)

schreiben wir immer noch 2018?
Hier sollte doch erstmal ein Update durchgeführt werden lt Wiki
https://www.willuhn.de/wiki/doku.php?id=support:update
Jameica 2.10.4
Hibiscus 2.10.15
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 10303
Dabei seit: 03 / 2005
Betreff:

Re: Fehlermeldung bei Auswertungen

 · 
Gepostet: 08.11.2023 - 07:49 Uhr  ·  #3
Deine Java-Version (8) ist zu alt. Jameica verlangt seit 11/2022 Java 11. Bisher ging es immer noch mit Java 8. So langsam mehren sich aber die potentiellen Fehlerstellen. Aktuelle Jameica-Versionen enthalten bereits eine passende Java-Version. Also aktualisiere Jameica wie unter https://www.willuhn.de/wiki/doku.php?id=support:update beschrieben. Die separate Java-Installation brauchst du dann nicht mehr (es sei denn, sie wird noch anderweitig verwendet).
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 2
Dabei seit: 11 / 2023
Betreff:

Re: Fehlermeldung bei Auswertungen

 · 
Gepostet: 08.11.2023 - 09:34 Uhr  ·  #4
Vielen Dank für die Rückmeldungen.
Ich habe jameica+Hibiscus nach vorigem Löschen des Programmverzeichnisses einfach nochmals neu installiert; jetzt funktionierts wieder einwandfrei.
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 10303
Dabei seit: 03 / 2005
Betreff:

Re: Fehlermeldung bei Auswertungen

 · 
Gepostet: 08.11.2023 - 09:37 Uhr  ·  #5
Bitte NIEMALS "drüberinstallieren". Siehe der deutliche eingerahmte Hinweis unter https://www.willuhn.de/wiki/doku.php?id=support:update

Zitat

ACHTUNG Kopiere niemals eine neue Programmversion über die alte Version. Da einige Programmbibliotheken Versionsnummern im Dateinamen tragen, würden sie nicht überschrieben werden und existieren anschliessend parallel in mehreren Versionen. Das führt anschliessend zu einem Versionsdurcheinander und Fehlern beim Programmstart. Lösche daher vorher erst das Programmverzeichnis von Jameica (nicht das Benutzerverzeichnis) und gehe anschließend wie bei einer Neuinstallation vor. Da die Benutzerdaten getrennt vom Programm gespeichert werden, gehen hierbei keine Daten verloren.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 14
Dabei seit: 12 / 2019
Betreff:

Re: Fehlermeldung bei Auswertungen

 · 
Gepostet: 09.11.2023 - 10:29 Uhr  ·  #6
Hallo,
ich habe dieselbe Fehlermeldung und dasselbe Problem, seit ich heute früh Hibiscus aufgerufen hatte. aber Linux Ubuntu 16.04. Hier wird über die Paketverwaltung offensichtlich keine höhere Version als die 8 installiert ( update-java-alternatives --list ergibt java-1.8.0-openjdk-amd64 1081 /usr/lib/jvm/java-1.8.0-openjdk-amd64) .
Die Java Version 11 ist im Unterverzeichnis von MTPlayer, als auch die 16 in meinem Unterverzeichnis von MediathekView auch auf dem Computer und wird von diesen Programmen aufgerufen.
Wieso ich noch Ubuntu 16.04 verwende, soll hier nicht Thema einer Diskussion sein. Nur kurz, die Installation der aktuellen LTS-Version 22.04 ist in Arbeit, zeitgleich mit dem Aufbau neuer Hardware, und auch der Übernahme und Neusortierung von 20 Jahren Daten und Programme ausserhalb der Paketverwaltung, was wochenlang dauern wird. Ich kann aber nicht so lange auf Banking und Buchhaltung verzichten.
Zuletzt davor hatte ich Hibiscus am 3. November 2023 genutzt, wie ich an den Backups sehe. Damit funktionierten auch die Menüpunkte unter "Auswertung" noch.
Das aktuelle Jameica funktionierte nach Umbenennung meines 2019er Programmverzeichnisses und Neuinstallation der heutigen Version 2023 bei Aufruf von jameica.sh schon mal garnicht, sodass ich auf die 2019er Version zurückging.
Falls nicht zufällig jemand einen Tipp hat, wie ich Jameica auf die Java Version 11 oder 16 statt der 8 zugreifen lassen kann (ich will nicht mit /usr/lib/jvm/default-java herumprobieren, ohne zu wissen, was ich tue ...): wie kann ich das Update von hibiscus rückgängig machen und auf den Stand vom 3.11.23 zurückkehren? Wo kann ich die älteren Versionen von hibiscus.zip downloaden? Kann ich die in's Benutzerverzeichnis .jameica/plugins/hibiscus einfach reinkopieren? Vermassele ich mir evtl. die heute (9.11.) heruntergeladenen Bankbewegungen?
Danke für jeden Tipp!

Gruß, Hannes
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 10303
Dabei seit: 03 / 2005
Betreff:

Re: Fehlermeldung bei Auswertungen

 · 
Gepostet: 09.11.2023 - 10:40 Uhr  ·  #7
Zitat

Das aktuelle Jameica funktionierte nach Umbenennung meines 2019er Programmverzeichnisses und Neuinstallation der heutigen Version 2023 bei Aufruf von jameica.sh schon mal garnicht, sodass ich auf die 2019er Version zurückging.

Ohne die konkreten Fehlermeldungen - https://www.willuhn.de/wiki/doku.php?id=support:fehlermelden - kann dir da keiner helfen.
Zitat

Falls nicht zufällig jemand einen Tipp hat, wie ich Jameica auf die Java Version 11 oder 16 statt der 8 zugreifen lassen kann (ich will nicht mit /usr/lib/jvm/default-java herumprobieren, ohne zu wissen, was ich tue ...)

Unter https://adoptium.net/de/ kann man alle Java-Versionen als Archiv zum manuellen Entpacken herunterladen und anschließend jameica.sh entsprechend anpassen, dass diese Java-Version verwendet wird.
Zitat

wie kann ich das Update von hibiscus rückgängig machen und auf den Stand vom 3.11.23 zurückkehren? Wo kann ich die älteren Versionen von hibiscus.zip downloaden?

https://www.willuhn.de/product….10.14.zip
Zitat

Kann ich die in's Benutzerverzeichnis .jameica/plugins/hibiscus einfach reinkopieren?

BITTE hört auf, Sachen irgendwo reinzukopieren.
Klicke in "Jameica auf Datei->Einstellungen->Plugins->Installierte Plugins" und wähle bei Hibiscus "Manuell aktualisieren...". Wähle dann die heruntergeladene ZIP-Datei aus.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 14
Dabei seit: 12 / 2019
Betreff:

Re: Fehlermeldung bei Auswertungen

 · 
Gepostet: 09.11.2023 - 11:38 Uhr  ·  #8
(Vor Glück heul) Danke für die schnelle Antwort!
2.10.15 löschen müssen (sinnvoll), 2.10.14 manuell installiert und die Auswertungen funktionieren wieder!
Noch schnell in Einstellungen -->Plugins-->Automatische Updates konfigurieren "Nur benachrichtigen" eingestellt.

Anmerkungen:
Zu "Fehlermeldungen": ich wusste nicht, daß es sich um einen behebbaren Fehler handeln könnte, und das aktuelle Log ist ein knappes Megabyte groß. Wenn man nicht sofort nach dem Ereignis nachguckt und auch weiß, daß das Log existiert, hat man keine Chance, die Einträge für diesen Installationsversuch zu finden.

Zu "adoptium.net": das habe ich schon nicht kapiert, als ich beim googlen selber drauf gestoßen war, und das jameica.sh geht über meine Fähigkeiten. Ich setze Hibiscus erstmal in der Version 10.14 auf hold und mit Ubuntu 22.04 werden alle derlei Probleme sich ja wohl erledigt haben :) .

Zu "hört auf, Sachen irgendwo reinzukopieren": <schäm> Hab ja aber wohlweislich vorher gefragt. Mit der Plugin-Verwaltung hat alles sofort geklappt.
Gewählte Zitate für Mehrfachzitierung:   0