Hibiscus startet nicht mehr nach KDE Plasma Update auf 5.21

Betriebssystem: KDE Neon mit OpenJDK 14

 
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 9
Dabei seit: 01 / 2015
Betreff:

Hibiscus startet nicht mehr nach KDE Plasma Update auf 5.21

 · 
Gepostet: 19.02.2021 - 04:28 Uhr  ·  #1
Hallo,

seit dem relativ großen Update auf KDE Plasma 5.21 startet Jameica nicht mehr. Wenn ich das Verzeichnis .jameica lösche startet es. Aber das ist keine Lösung: Ich möchte wieder meine ganzen Umsätze! Auch das Einspielen eines Backups mit einem "leeren, frischen" .jameica Verzeichnis funktioniert nicht. Nach Einspielen des Backups wird Jameica beendet und danach startet es nicht mehr.
Danke

Viele Grüße
user698
Der an diesem Beitrag angefügte Anhang ist entweder nur im eingeloggten Zustand sichtbar oder die Berechtigung Deiner Benutzergruppe ist nicht ausreichend.
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 9144
Dabei seit: 03 / 2005
Betreff:

Re: Hibiscus startet nicht mehr nach KDE Plasma Update auf 5.21

 · 
Gepostet: 19.02.2021 - 07:14 Uhr  ·  #2
Das hat nichts mit dem KDE-Update zu tun. Ich hab das selbst gestern auch gemacht und Hibiscus startet weiterhin. Ich wuesste auch keinen moeglichen Zusammenhang.

DIe Fehlermeldung in deinem Log deutet darauf hin, dass die Anwendung bereits laeuft und du versuchst, sie noch ein zweites mal zu starten. Die Datenbank verweigert sich dann, weil sie bereits durch einen anderen Prozess gesperrt ist.

Starte mal den Rechner neu, um sicherzustellen, dass da kein Prozess die Datenbank blockiert.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 9
Dabei seit: 01 / 2015
Betreff:

Re: Hibiscus startet nicht mehr nach KDE Plasma Update auf 5.21

 · 
Gepostet: 19.02.2021 - 15:03 Uhr  ·  #3
Danke. Mit dem Starten, obwohl schon eine Instanz von Jameica läuft, hat es nichts zu tun. Ich habe gerade den PC hochgefahren und das Problem besteht weiterhin. Ich starte, es kommt die Passwortabfrage, dann der blaue Splash Screen, der nach ein paar Sekunden verschwindet und dann ... nichts ... Jameica startet nicht

Im Anhang das auf heute bzw. jetzt gekürzte Logfile.
Der an diesem Beitrag angefügte Anhang ist entweder nur im eingeloggten Zustand sichtbar oder die Berechtigung Deiner Benutzergruppe ist nicht ausreichend.
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 9144
Dabei seit: 03 / 2005
Betreff:

Re: Hibiscus startet nicht mehr nach KDE Plasma Update auf 5.21

 · 
Gepostet: 19.02.2021 - 15:14 Uhr  ·  #4
In dem Log sehe ich keine Fehlermeldung sondern nur den fehlerfreien Start der Anwendung um 14:52 Uhr. Da sieht man auch, dass die GUI geladen wurde. Unter Umständen läuft dein Desktop seit dem KDE-Update jetzt nicht mehr mit X11 sondern mit Wayland. Unter Umständen unterstützt Wayland GTK-basierte Anwendungen noch nicht.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 9
Dabei seit: 01 / 2015
Betreff:

Re: Hibiscus startet nicht mehr nach KDE Plasma Update auf 5.21

 · 
Gepostet: 19.02.2021 - 15:39 Uhr  ·  #5
Ja, ich habe beim Plasma-Login Wayland ausgewählt statt X11, weil es Probleme mit dem Desktop gab. Ich konnte die Fensterleiste nicht mehr anklicken.
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 9144
Dabei seit: 03 / 2005
Betreff:

Re: Hibiscus startet nicht mehr nach KDE Plasma Update auf 5.21

 · 
Gepostet: 19.02.2021 - 15:41 Uhr  ·  #6
Dann versuch doch stattdessen mal X11.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 9
Dabei seit: 01 / 2015
Betreff:

Re: Hibiscus startet nicht mehr nach KDE Plasma Update auf 5.21

 · 
Gepostet: 19.02.2021 - 15:44 Uhr  ·  #7
Mit X11 geht es jetzt wieder. Danke. Aber ich konnte vorhin unter Wayland Gparted problemlos starten. Ist Gparted nicht auch eine GTK-Anwendung? Muss man vielleicht Jameica noch auf Wayland anpassen?
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 9144
Dabei seit: 03 / 2005
Betreff:

Re: Hibiscus startet nicht mehr nach KDE Plasma Update auf 5.21

 · 
Gepostet: 19.02.2021 - 15:48 Uhr  ·  #8
Zitat geschrieben von user698

Mit X11 geht es jetzt wieder. Danke. Aber ich konnte vorhin unter Wayland Gparted problemlos starten. Ist Gparted nicht auch eine GTK-Anwendung? Muss man vielleicht Jameica noch auf Wayland anpassen?


Jameica verwendet SWT (https://www.eclipse.org/swt/). Das wiederrum verwendet intern GTK. Wenn, dann müssten die Anpassungen in SWT vorgenommen werden. Aber auch das ist nicht der Fall. Der Display-Server - also kwin muss GTK unterstützen. Nach meinem Wissen tut er das auch.

Es könnte aber auch sein, dass du Jameica manuell auf GTK2 konfiguriert hast. Siehe https://www.willuhn.de/wiki/do…nter_linux
GTK2 gilt als veraltet und wird von Wayland nicht unterstützt.

In Jameica selbst kann ich da nichts ändern.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 9
Dabei seit: 01 / 2015
Betreff:

Re: Hibiscus startet nicht mehr nach KDE Plasma Update auf 5.21

 · 
Gepostet: 19.02.2021 - 15:59 Uhr  ·  #9
Also in jameica.sh ist nichts manuell verändert worden: SWT_GTK3=1
Vielleicht funktioniert Wayland dann mit der nächsten Jameica-Version ... Oder fehlt vielleicht noch irgendein spezielles Paket? Keine Ahnung ...
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 9144
Dabei seit: 03 / 2005
Betreff:

Re: Hibiscus startet nicht mehr nach KDE Plasma Update auf 5.21

 · 
Gepostet: 19.02.2021 - 16:14 Uhr  ·  #10
Zitat geschrieben von user698

Vielleicht funktioniert Wayland dann mit der nächsten Jameica-Version ...

Eine nächste Jameica-Version wird daran nichts ändern, weil ich wie gesagt in Jameica nichts ändern kann, was mit Wayland im Zusammenhang steht.

Um einen hinkenden Vergleich zu bringen: Wenn die Strasse vom Auto nicht befahrbar ist, kann das Autoradio daran nichts ändern.

Laut https://bugs.eclipse.org/bugs/show_bug.cgi?id=496923 sollte SWT auch schon seit Jahren Wayland-Support enthalten. Es sollte also eigentlich funktionieren.

Zitat geschrieben von user698

Oder fehlt vielleicht noch irgendein spezielles Paket?


Das weiss ich leider nicht.

Ich habe es jetzt mal selbst getestet. KDE Plasma 5.21 auf SuSE Tumbleweed. Habe beide Session-Varianten "Full Wayland" und "Wayland" (was auch immer da bei SuSE der Unterschied ist). Hat in beiden funktioniert. Der Splashscreen wird zwar bei der "Full Wayland"-Version mit Fenster-Dekoration angezeigt. Aber funktionieren tut alles. In der Variante "Wayland" wird alles korrekt angezeigt.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 9
Dabei seit: 01 / 2015
Betreff:

Re: Hibiscus startet nicht mehr nach KDE Plasma Update auf 5.21

 · 
Gepostet: 19.02.2021 - 16:25 Uhr  ·  #11
Okay, aber wo befindet sich dann das SWT? Ist das ein spezielles, externes Paket?

Mir fiel gerade wieder ein: Wenn ich das alte .jameica-Verzeichnis lösche und ein neues erstellen lasse, funktioniert ja alles, dann startet Jameica, ich müsste halt dann alles neu konfigurieren und meine alten Umsätze wären weg. Also muss an meinem alten jameica-Profil irgendetwas mit Wayland nicht zusammenspielen ... Weißt du vielleicht, was das sein könnte?
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 9144
Dabei seit: 03 / 2005
Betreff:

Re: Hibiscus startet nicht mehr nach KDE Plasma Update auf 5.21

 · 
Gepostet: 19.02.2021 - 16:31 Uhr  ·  #12
Zitat geschrieben von user698

Okay, aber wo befindet sich dann das SWT? Ist das ein spezielles, externes Paket?

Das ist in Jameica direkt integriert.
Von wo hast du Jameica denn heruntergeladen/installiert? Welche Version verwendest du? Wird im Menü unter "Hilfe->Über" angezeigt.

Zitat geschrieben von user698

Mir fiel gerade wieder ein: Wenn ich das alte .jameica-Verzeichnis lösche und ein neues erstellen lasse, funktioniert ja alles, dann startet Jameica, ich müsste halt dann alles neu konfigurieren und meine alten Umsätze wären weg. Also muss an meinem alten jameica-Profil irgendetwas mit Wayland nicht zusammenspielen ... Weißt du vielleicht, was das sein könnte?

Nein. Beim besten Willen wüsste ich nicht, was die Daten mit Wayland zu tun haben. Bei mir funktionierte es in einem Test ja auch mit den existierenden Daten.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 9
Dabei seit: 01 / 2015
Betreff:

Re: Hibiscus startet nicht mehr nach KDE Plasma Update auf 5.21

 · 
Gepostet: 19.02.2021 - 16:44 Uhr  ·  #13
Zitat geschrieben von hibiscus

Von wo hast du Jameica denn heruntergeladen/installiert? Welche Version verwendest du? Wird im Menü unter "Hilfe->Über" angezeigt.

Ich habs von deiner Seite runtergeladen:

Version: 2.10.0
SWT-Version: 4936 / gtk
Java-Version: 14.0.2 / Linux amd64
Build: 480 [Datum 20201127]

Aber eins verstehe ich nicht: Wenn SWT direkt in Jameica integriert ist, wird dann bei einer neuen Jameica-Version nicht auch die aktuelle Version von SWT verwendet? Wird SWT da nicht mitaktualisiert?

Zitat geschrieben von hibiscus

Nein. Beim besten Willen wüsste ich nicht, was die Daten mit Wayland zu tun haben. Bei mir funktionierte es in einem Test ja auch mit den existierenden Daten.

Seltsam, bei mir funktioniert es nur mit einem frischen Profil.
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 9144
Dabei seit: 03 / 2005
Betreff:

Re: Hibiscus startet nicht mehr nach KDE Plasma Update auf 5.21

 · 
Gepostet: 19.02.2021 - 16:47 Uhr  ·  #14
Zitat geschrieben von user698

Aber eins verstehe ich nicht: Wenn SWT direkt in Jameica integriert ist, wird dann bei einer neuen Jameica-Version nicht auch die aktuelle Version von SWT verwendet? Wird SWT da nicht mitaktualisiert?

ja, natürlich. SWT ist aber nicht die Ursache. Deswegen wird eine aktuellere Version davon das Problem nicht lösen. SWT ist das Autoradio.
Neuling
Avatar
Geschlecht: keine Angabe
Beiträge: 1
Dabei seit: 11 / 2022
Betreff:

Re: Hibiscus startet nicht mehr nach KDE Plasma Update auf 5.21

 · 
Gepostet: 24.11.2022 - 13:47 Uhr  ·  #15
Zitat geschrieben von hibiscus

ja, natürlich. SWT ist aber nicht die Ursache. Deswegen wird eine aktuellere Version davon das Problem nicht lösen. SWT ist das Autoradio.

Hallo,

die Lösung besteht darin in das Startskript jameica.sh noch folgende Variable zu setzen.
Code
GDK_BACKEND=x11 


Die ganze Zeile sieht dann so aus
Code
GDK_BACKEND=x11 LIBOVERLAY_SCROLLBAR=0 GDK_NATIVE_WINDOWS=1 SWT_GTK3=1 exec javaruntime/bin/java $_JLP -Djava.net.preferIPv4Stack=true -Xmx512m -Xss64m $_JCONSOLE -jar jameica-linux${archsuffix}.jar $@


Viele Grüße
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 9144
Dabei seit: 03 / 2005
Betreff:

Re: Hibiscus startet nicht mehr nach KDE Plasma Update auf 5.21

 · 
Gepostet: 24.11.2022 - 13:57 Uhr  ·  #16
Gewählte Zitate für Mehrfachzitierung:   0