Postbank / BestSign

Login erfordert BestSign-Freigabe

 
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 43
Dabei seit: 03 / 2015
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 17:32 Uhr  ·  #81
Wenn du ne Idee hast die ich ausprobieren soll kann ich auch gerne einen github hbci4java Branch testen.... Das Verhalten ist ja mit InitAndTest identisch - ist vielleicht einfacher als Trial&Error mittels Nightly Builds von Hibiscus.... Bin leider selber jetzt nicht mit HBCI bewandert.
Du kannst mir aber auch Patches schicken gegenüber master oder oder oder..... was auch immer hilft.
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 7096
Dabei seit: 03 / 2005
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 17:35 Uhr  ·  #82
Ja, gute Idee. Ich gebe Bescheid, wenn ich was eingebaut hab. Wobei - wie gesagt: Grundsätzlich sollte die Postbank funktionieren. Das Stolpern passierte nur bei der Synchronisierung. Heisst: Beim ersten Klick auf "Konfiguration testen" sollte es zu dem Fehler kommen, weil Hibiscus das TAN-Verfahren wechselt und die Postbank drüber stolpert. Beim zweiten Mal hat es dann aber das neue TAN-Verfahren und es sollte kein Fehler mehr auftreten.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 3
Dabei seit: 09 / 2019
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 17:53 Uhr  ·  #83
Bei mir geht der Abruf des Postbank-Kontos nur mit einem komplett neuen Profil. In meinem alten Profil versucht Hibiscus, egal was ich mache, noch die Daten über das alte TAN-Verfahren abzuholen.

Im Log sieht man gut, wie immer noch die SMS-TAN versucht wird:
Code
having exactly one TAN media name (provided by institute) - automatically using this: mT:Telefon


Ich habe so langsam die Vermutung, dass das Verfahren noch irgendwo in den UPD-Daten hängt. Es gibt dort ja auch den UPD-Eintrag "tanmedia.names". Nur kann ich diese Daten nicht löschen.

Ich könnte auch mit der Neuanlage des Kontos leben, wenn ich irgendwie meine alten Daten übernehmen/verknüpfen könnte.

Ich kann auch gerne das komplette Log zur Verfügung stellen, wenn es helfen sollte.
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 7096
Dabei seit: 03 / 2005
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 17:58 Uhr  ·  #84
Zitat geschrieben von Jeddix

Ich habe so langsam die Vermutung, dass das Verfahren noch irgendwo in den UPD-Daten hängt. Es gibt dort ja auch den UPD-Eintrag "tanmedia.names". Nur kann ich diese Daten nicht löschen.


Spätestens wenn du den Bankzugang löschst und neu anlegst, ist diese Information weg.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 19
Dabei seit: 09 / 2018
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 18:11 Uhr  ·  #85
Zitat geschrieben von hibiscus

Beim zweiten Mal hat es dann aber das neue TAN-Verfahren und es sollte kein Fehler mehr auftreten.


Guten Abend,
leider kann ich diese Aussage nicht bestätigen. Seit Sonntag versuche ich mit allen denkbaren (und undenkbaren) Möglichkeiten,
eine Postbankabfrage mit Hibiscus ans Laufen zu bringen. Nichts hat bisher zum Erfolg geführt. Das ich mir alle Beiträge und Ratschläge zu diesem Thema aufmerksam durchgelesen und ggfls. ausprobiert habe, versteht sich von selbst.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 43
Dabei seit: 03 / 2015
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 18:15 Uhr  ·  #86
@Niagara - ja in diesem Zustand war ich auch. Einmal das Konto mit der Testversion von StarMoney eingerichtet - danach ging es auch mit Jamaica / Hibiscus (nach dem 2. Versuch) Vorher kamen immer die Fehlermeldungen

Code
<ERR> [2019.09.10 20:39:37.702] [main/main] status.HBCIStatus: Meldung der Bank: 9964:Der Auftrag kann nicht mit dem gewählten Seal One legitimiert werden. (5: Synch.TAN2Step6)


oder

Code
<ERR> [2019.09.10 20:31:56.996] [main/main] status.HBCIStatus: Meldung der Bank: 9962:Der Auftrag kann nicht mit der gewählten Mobilfunknummer legitimiert werden. (5: Synch.TAN2Step6)



Zitat geschrieben von hibiscus

Ja, gute Idee. Ich gebe Bescheid, wenn ich was eingebaut hab. Wobei - wie gesagt: Grundsätzlich sollte die Postbank funktionieren. Das Stolpern passierte nur bei der Synchronisierung. Heisst: Beim ersten Klick auf "Konfiguration testen" sollte es zu dem Fehler kommen, weil Hibiscus das TAN-Verfahren wechselt und die Postbank drüber stolpert. Beim zweiten Mal hat es dann aber das neue TAN-Verfahren und es sollte kein Fehler mehr auftreten.


Jo klar - beim 2. und jedem weiteren Versuch klappt es. Ist halt in Summe etwas unschön.
Eigentlich bleibt auch noch der Punkt das es initial ja auch gar nicht klappte - erst als ich mich einmal mit StarMoney verbunden habe und via BestSign authorisiert habe ist ja auch hibiscus in den Zustand gekommen das es nun nach dem 2. und jedem weiteren Male funktioniert. Davor war ja grundsätzlich Ebbe.
Was auch immer StarMoney gemacht hat um diesen Zustand zu erreichen - ich vermute andere Postbank-Kunden könnten die gleichen Probleme haben.....

Also - wenn du überlegt hast und ich was testen soll - melde dich einfach ;)
Benutzer
Avatar
Geschlecht: keine Angabe
Herkunft: Leipzig
Homepage: willuhn.de/
Beiträge: 7096
Dabei seit: 03 / 2005
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 18:18 Uhr  ·  #87
Zitat geschrieben von OlliL

Also - wenn du überlegt hast und ich was testen soll - melde dich einfach ;)

Das Log, welches du mir geschickt hast - stammte das von der Neuanlage eines Bankzugangs - also erster Versuch? Dann wäre das fehlende Dialog-Ende bei dem Sync der einzige Fehler.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 19
Dabei seit: 09 / 2018
Betreff:

Postbank-Antwort

 · 
Gepostet: 11.09.2019 - 18:19 Uhr  ·  #88
Auf meine Beschwerde erhielt ich von der Postbank heute folgende Antwort:

Zitat Anfang:
Sehr geehrte Kundin, sehr geehrter Kunde,

vielen Dank für Ihre E-Mail. Seit den Wartungsarbeiten am letzten Wochenende tritt bei Ihrem Finanzsoftwareprodukt eine Störung auf. Vermutlich unterstützt Ihre verwendete Finanzsoftware die starke Authentifizierung nicht. Dies betrifft auch HBCI.

Wir haben von vielen Herstellern eine Rückmeldung erhalten, wie mit der Störung umzugehen ist. Falls die unten angegebenen Informationen Ihnen nicht helfen sollten, wenden Sie sich bitte an Ihren Hersteller:

• ALF Banco: Ein Patch ist direkt aus der Finanzsoftware heraus abrufbar
• SFirm: Ein Patch ist bereits vom Hersteller verfügbar unter "Patches und Featurepacks" > "Starten"
• ProfiCash: Ein Patch ist am 12.09.2019 vorgesehen.
• StarMoney/Starfinanz: Alle hinterlegten Kontakte zu Postbank-Konten müsse gelöscht und neu angelegt werden. (hier bitte die Anleitung in der Anlage beachten)
• Quicken-Haufe-Lexware: Ein Patch wird im laufe des Tages bereitgestellt
• Moneyplex: Ein Patch wurde bereitgestellt
• Windata: Ein Patch wurde bereitgestellt. Wenn dies nicht funktioniert hat, beachten Sie bitte die Anleitung)
• Datev: Es steht ein Update bereit (hier bitte die Anleitung in der Anlage beachten).
• Wieso Mein Geld/Buhl Data: Ein Patch wird per über ein Zwangsupdate bei der nächsten Nutzung installiert

Bitte stellen Sie sicher, dass die richtigen Anmeldeinformationen (Postbank ID und Passwort) hinterlegt sind.

Mit freundlichen Grüßen
Ihr Postbank E-Mail-Team-16
Zitat Ende
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 43
Dabei seit: 03 / 2015
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 18:20 Uhr  ·  #89
Zitat geschrieben von hibiscus

Zitat geschrieben von OlliL

Also - wenn du überlegt hast und ich was testen soll - melde dich einfach ;)

Das Log, welches du mir geschickt hast - stammte das von der Neuanlage eines Bankzugangs - also erster Versuch? Dann wäre das fehlende Dialog-Ende bei dem Sync der einzige Fehler.


Ja - das Log enthällt nur 2 Klicke auf Bank-Zugänge -> [Konfiguration testen]. Der erste Klick ist der Teil über den Leerzeilen - der zweite Klick ist unter den Leerzeilen....
Benutzer
Avatar
Geschlecht:
Beiträge: 4742
Dabei seit: 06 / 2008
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 18:22 Uhr  ·  #90
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 19
Dabei seit: 09 / 2018
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 18:27 Uhr  ·  #91
@infoman

Selbstverständlich; mehrfach in zahlreichen Variationen!
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 43
Dabei seit: 03 / 2015
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 18:38 Uhr  ·  #92
@Niagara

Wie schon geschrieben - irgendwas hängt da noch schief wo bei mir StarMoney zur Selbstheilung verhalf. Du kannst ja mal im HBCI Protokoll nach der Fehlermeldung suchen. Ich tippe auf eine von den beiden:

9964::Der Auftrag kann nicht mit dem gewählten Seal One legitimiert werden.
9962::Der Auftrag kann nicht mit der gewählten Mobilfunknummer legitimiert werden.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 19
Dabei seit: 09 / 2018
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 19:03 Uhr  ·  #93
@ iOlliL

[11.09.2019 18:58:18] test of passport failed: class org.kapott.hbci.exceptions.ProcessException: Fehler beim Ermitteln einer neuen System-ID
Benutzer
Avatar
Geschlecht:
Beiträge: 4742
Dabei seit: 06 / 2008
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 19:12 Uhr  ·  #94
@Niagara
dann probier doch auch mal die SM-Testversion, vielleicht ist das von @OlliL wirklich ein workaround, irgendetwas "gerade" zu biegen. (was auch immer dieses woodoo dann wäre)
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 3
Dabei seit: 09 / 2019
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 19:15 Uhr  ·  #95
Olli, musstest du nach der BestSign-Authentifizierung in Starmoney nochmal in Hibiscus eine TAN eingeben? Bei mir kam dort keine Abfrage oder Freigabe mehr in Hibiscus.

Also bei mir lief es so: Konto in Starmoney anlegen, dort BestSign auswählen und die TAN aus der App abtippen. -> Konto in Hibiscus anlegen, BestSign auswählen (hier kam jetzt zum ersten Mal seit der Umstellung auf BestSign auch die Abfrage nach dem Namen des Verfahrens), Online-PIN eingeben.
Es kam keine Abfrage irgendeiner TAN, ich konnte direkt das Konto synchronisieren.

Ich vermute, dass in dem Fall wirklich Starmoney dazu geführt hat, dass die BestSign-Authentifizierung funktioniert hat.

@hibiscus: Ich wusste nicht, dass ich den Bankzugang löschen kann ohne die restlichen Daten zu löschen. Das habe ich also auch getan, nur bekomme ich jetzt bei einem neuen Bankzugang nicht einmal mehr die Box zur Auswahl des TAN-Verfahrens angezeigt (der Button für das Zurücksetzen des TAN-Verfahrens ist auch deaktiviert).

Im Log gibt es eine org.kapott.hbci.exceptions.CanNotParseMessageException. Ein Teil des ellenlangen Strings danach ist
Code
HIRMS:4:2:4+1040::BPD nicht mehr aktuell. Aktuelle Version folgt.+3920::Meldung unterstützter Ein- und Zwei-Schritt-Verfahren:920+3076::Keine starke Authentifizierung erforderlich.+1050::UPD nicht mehr aktuell. Aktuelle Version folgt.


BPD hatte ich vorher noch gelöscht. Das Fenster der BPD/UPD-Variablen ist also vor der Synchronisierung leer.

Das geht dann im Callstack runter bis zu einer
Code
org.kapott.hbci.exceptions.ParseErrorException: SynchRes.MsgTail.SegHead.code: vorgegebener Wert "HNHBS" stimmt nicht mit gefundenem Wert "HISYN" überein
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 43
Dabei seit: 03 / 2015
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 19:27 Uhr  ·  #96
Zitat geschrieben von Niagara

@ iOlliL

[11.09.2019 18:58:18] test of passport failed: class org.kapott.hbci.exceptions.ProcessException: Fehler beim Ermitteln einer neuen System-ID


Du musst über Das Menue oben Hibiscus -> Erweitert -> HBCI PRotokoll speichern das Protokoll in eine Datei speichern. Dort drin kannst du dann nach den Fehlermeldungen suchen welche die Bank gesendet hat.

Aber nicht das ganze Log hier posten - da stehen ID und PIN fürs Onlinebanking drin....
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 43
Dabei seit: 03 / 2015
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 19:29 Uhr  ·  #97
Zitat geschrieben von Jeddix

Olli, musstest du nach der BestSign-Authentifizierung in Starmoney nochmal in Hibiscus eine TAN eingeben? Bei mir kam dort keine Abfrage oder Freigabe mehr in Hibiscus.


Ich hatte vorher kein StarMoney - somit habe ich das Konto dort komplett neu eingerichtet. Die TAN musste ich nur in Starmoney eingeben. Dann in Hibiscus nix mehr - ich musste dort nur den Namen der Bestsign-Konfiguration eintippen - der stand ja noch in Starmoney (SO:<Text wie im Onlinebanking>). Danach lief es mit Hibiscus.

Die Authorisation für HBCI hällt ja eine Weile an. Ich meine man muss sich einmal alle 90 Tage via Bestsign autorisieren. Also schauen wir mal wie das dann in 3 Monaten mit hibiscus aussieht ob das mit der TAN Eingabe dann dort klappt.....
Neuling
Avatar
Geschlecht: keine Angabe
Beiträge: 1
Dabei seit: 09 / 2019
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 19:55 Uhr  ·  #98
Ich kann ebenfalls bestätigen, dass es bei mir nach der "Ersteinrichtung" über die StarMoney Testversion anschließend über Hibiscus funktioniert hat.
Benutzer
Avatar
Geschlecht: keine Angabe
Beiträge: 3
Dabei seit: 09 / 2019
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 20:32 Uhr  ·  #99
Bei mir funktionierte es erst auch nicht. Immer wieder die Fehlermeldungen wie alle anderen (unter anderem "Fehler beim Ermitteln einer neuen System-ID"). Auch das Neuanlegen einer Kontoverbindung ging nicht genau wie die anderen Tips im Forum. Nachdem ich mich mit finanzblick angemeldet hatte (mit Tan aus bestsign) konnte ich die Kontoverbindung auch in Hibiskus problemlos testen und die Konten anschließen synchronisieren. Eine Abfrage in der Bestsign App erfolgte in Hibiskus nicht.

Ich hatte vor wenigen Tagen von einer sehr alten Version mit " hibiscus-mashup.derrichter.de " auf die neuste Version aktualisiert (windows 10, 32 Bit) damit der Posbankzugang wieder geht. Nutzte die App bisher nur zur Überwachung der Kontobewegungen. Überweichungen mache ich woanders
Benutzer
Avatar
Geschlecht:
Beiträge: 4742
Dabei seit: 06 / 2008
Betreff:

Re: Postbank / BestSign

 · 
Gepostet: 11.09.2019 - 20:40 Uhr  ·  #100
Zitat geschrieben von Grayhound6
...finanzblick...

bevor manche (voreilig) diesen Service nutzen, je nach Einstellungen wird die Cloud/Web-Service verwendet, was manche User nicht wünschen.
Dies ist eine Einstellungssache bei der App usw. (geht also ohne und mit Cloud)
bzw. selbst der Cloud-Services muss grundsätzlich nicht schlimm sein, wenn man als User hierüber bescheid weiß und es/diesen trotzdem nutzt.
Gewählte Zitate für Mehrfachzitierung:   0